System Requirements for Cuphead: The Delicious Last Course DLC - Prima Games

System Requirements for Cuphead: The Delicious Last Course DLC

Will your rig run it? *gasp*

by Nikola L

When you look at Cuphead’s graphics, you may think that the 1930s style can be run by any computer, including notable computers from that era, such as ABC, ENIAC, Colossus, Harvard Mark 1, EDVAC, or any other computer “forefathers.” Well, you’d be wrong. Even though the game truly has low minimum system requirements for something that’s new on the market, you’ll still need a rig that’s from the 2010s (or younger) in order to run Cuphead and its DLC. Here are the PC system requirements for Cuphead: The Delicious Last Course.

Minimum System Requirements for Cuphead: The Delicious Last Course DLC

Below, we will show you the Minimum System Requirements for PC and Mac. Consoles run the game normally as it has been fully optimized for the hardware on them, so you’ll have no worries if you’re a PlayStation, Xbox, or Nintendo Switch player. Computer players on the other hand…

Please note that Minimum System Requirements have slightly risen since the release of the original Cuphead.

PC (Windows) Minimum System Requirements for Cuphead: The Delicious Last Course DLC

You will need a 64-bit processor and operating system in order to run Cuphead on Windows.

Operating System: Windows 10
Processor (CPU): Intel Core2 Duo E8400
Random Access Memory (RAM): 4 GB RAM
Graphics Card (GPU): Anything that has 2GB VRAM or more
DirectX: Version 11
Storage (SDD/HDD): 2 GB of available space

Mac Minimum System Requirements for Cuphead: The Delicious Last Course DLC

You will need a 64-bit processor and operating system in order to run Cuphead on Mac.

Operating System: macOS 10.11.x
Processor (CPU): Intel Core i5 or higher
Random Access Memory (RAM): 4 GB RAM or more
Graphics Card (GPU): Intel HD Graphics 4000 or better (requires Metal)
Storage (SDD/HDD): 2 GB of available space

You may also like